It is currently Wed 28 Oct 2020 - 23:57 - créer un forum

[Résolu] Profils en hover sur les avatars

Skip to content

Post new topic Reply to topic

[Résolu] Profils en hover sur les avatars
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Sat 14 Dec 2019 - 05:34    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

PublicitéSupprimer les publicités ?
Bonjour :)

Je viens vers vous pour vous demander un peu aide et/ou des explications sur un problème.
Il y a quelques temps de ça, j'avais refait entièrement l'apparence de mon forum. J'avais miraculeusement réussi à installer le profil (nombre de messages, date d'inscription,...) en hover sur l'avatar.
Je dis miraculeusement car déjà à l'époque ça ne fonctionnait pas toujours, selon les profils et les moteurs de recherche (mystère....). Souvent il s'affichait sur un message sur deux.

Aujourd'hui ça ne fonctionne plus et on ne peut plus voir les profils. Mon forum étant actif qu'à certaines périodes c'est difficile pour moi de savoir quand cela a arrêté de fonctionner. Je me demandais si vous pouviez m'aider ou m'apporter des précisions pour faire fonctionner ce code car j'aime bien le côté épuré que ça donne aux messages.

C'est un code CSS que j'ai mis dans overall_header.tpl


Code: Sélectionner - Agrandir
.avatar_mess
    {
position: relative;
      width: 200px;
      height: 335px;
      margin-left: 10px;
      margin-right: 10px;
      overflow: hidden;
      background: #F2F2F2;
      border: 5px solid #F2F2F2;

      box-shadow: 0px 0px 6px #000000;
      -moz-box-shadow: 0px 0px 6px #000000;
      -o-box-shadow: 0px 0px 6px #000000;
      -htm-box-shadow: 0px 0px 6px #000000;
      -webkit-box-shadow: 0px 0px 6px #000000;
          transform: all;
    -moz-transform: all;
    -o-transform: all;
    -htm-transform: all;
    -webkit-transform: all;
   
-webkit-border-radius: 5px;
-moz-border-radius: 5px;
border-radius: 5px;

transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;

}

    .avatar_mess:hover
    {
      margin-left: 10px;
          transform: all;
    -moz-transform: all;
    -o-transform: all;
    -htm-transform: all;
    -webkit-transform: all;
    transition: 1s;
    -moz-transition: 1s;
    -o-transition: 1s;
    -htm-transition: 1s;
    -webkit-transition: 1s;

    }

.avatarhover{
    position: relative;
z-index: 2;
}

    .avatarhover:hover{
      opacity: 0;
      -moz-opacity: 0;
      -khtml-opacity: 0;
      filter: alpha(opacity=0);
    }


    .profil_mess{
      display: block;
      width: 200px;
      height: 320px;
      margin: auto;
      padding: 0px;
      overflow: auto;
      background: #FFFFFF;
      color: #372314;
    position: absolute;
   font-size: 12px;
    z-index: 1;
  opacity: 0;
 -moz-opacity: 0;
  -khtml-opacity: 0;
  filter: alpha(opacity=0);
      transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition:  1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;
}

.profil_mess:hover
{
  margin-left: 0px;
margin-top: -12px;
width: 200px;
height: 320px;
  opacity: 0.8;
  -moz-opacity: 1;
  -khtml-opacity: 1;
  filter: alpha(opacity=0);
      transform: all;
-moz-transform: all;
-o-transform: all;
-htm-transform: all;
-webkit-transform: all;
transition: 1s;
-moz-transition: 1s;
-o-transition: 1s;
-htm-transition: 1s;
-webkit-transition: 1s;


}

.pseudo_mess
{
  display: block;
position: relative;
  width: 200px;
  margin-top: 15px;
  margin-left: 25px;
  text-align: center;
  font-size: 18px;
  font-weight: bold;
  text-shadow: 0px 0px 0px ;
  background: #F2F2F2;
  padding-top: 5px;
  padding-bottom: 5px;
-webkit-border-radius: 50px;
-moz-border-radius: 50px;
border-radius: 50px;
}


_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Author Message
Sploutch
Contributeurs


Offline
Contributeurs

Joined: 02 Jan 2006
Posts: 1,200
Niveau:
Point(s): 1,252
Moyenne: 1.04
Mac Safari Masculin

PostPosted: Sat 14 Dec 2019 - 08:59    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bonjour Yume-sama,

Je pense que le mieux et de repartir sur du neuf, surtout si les modifications et script .css etc ne fonctionne plus.

Vous avez pas mal de tutoriels que j'ai crée pour modifier les affichages des informations sous l'avatar.
Des modèles customisés avec encadrement ou pas, avec effet ou pas, en hover etc dans le même but que vous !

Entre autre celui-ci :
https://forumtutorielssupports.xoo.it/t289-Tuto-Afficher-le-profil-du-membr…

N'hésitez pas à consulter la liste qui offre d'autres options pour l'avatar mais pas que !

Cdlt
_______________________

Nous avons actuellement 386 Tutoriels ici pour personnalisez votre forum avec des exclusivités xooit !


Forum
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Sat 14 Dec 2019 - 09:13    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Génial merci beaucoup pour la réponse , je suis tout à fait pour repartir sur un code neuf, je vais regarder ça Very Happy
_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Sat 14 Dec 2019 - 12:01    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Je ne sais pas si si je dois éditer mon message ou en écrire un autre.


J'ai regardé mais malheureusement ça ne fonctionne toujours pas... J'ai pu vérifié sur les publicités : le bloc de profil apparaît bien, et je pense que c'est parce qu'il n'y a pas d'avatar. Donc il y a certainement une solution plus simple, certainement juste un tout petit réglage à faire j'imagine dans VIEWTOPIC_BODY.TPL
Voici la partie du code :

Code: Sélectionner - Agrandir
<td width="300" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><br/><br/><br/><a name="{postrow.U_POST_ID}"></a><b>{postrow.RANK_IMAGE}

<div class="avatar_mess"> <div style="text-align: center;">
 {postrow.POSTER_AVATAR} <div class="profil_mess">{postrow.POSTER_JOINED}<br/>{postrow.POSTER_POSTS}<br/>{postrow.POSTER_FROM}</div></div></div>
                         
<span class="pseudo_mess" style="text-align: center;">
<font size=2>{postrow.POSTER_RANK}</font><br/>
<font size=3><b>{postrow.POSTER_NAME}</b></font></span><br /></td>

_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Author Message
Sploutch
Contributeurs


Offline
Contributeurs

Joined: 02 Jan 2006
Posts: 1,200
Niveau:
Point(s): 1,252
Moyenne: 1.04
Mac Safari Masculin

PostPosted: Sat 14 Dec 2019 - 15:05    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bonjour,

Bien sur que SI !
Le tutoriel fonctionne très bien.

Vous n'êtes pas arrivé à le mettre en place ce qui est surement diffèrent, mais pour autant, tous fonctionne !
Par ailleurs le support se fait à la suite du tutoriel !

Cdlt
_______________________

Nous avons actuellement 386 Tutoriels ici pour personnalisez votre forum avec des exclusivités xooit !


Forum
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Sun 15 Dec 2019 - 01:34    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Oui oui, je veux dire que dans mon cas je n'arrive pas à le faire fonctionner, mais ça me semblait évident. Je vous bien qu'il fonctionne sur l'autre forum.
Sur mon forum il doit y avoir une balise mal placée ou une bêtise comme ça. Mais j'ai beau vérifier je ne trouve pas. Je suis quasiment sure que le profil s'affiche bien comme prévu mais derrière l'avatar.... je vérifie les codes mais rien ne me choque ! C'edt vraiment étrange.
J'avais essayé de remplacé la balise div du code css du profil et de l'avatar dans le template viewtopic body par une balise span. Ça avait tout chamboulé bien sûr mais je pouvais voir l'animation des profils. Donc ce n'est pas la code qui ne fonctionne plus finalement...

EDIT : J'ai changé encore le code et je ne sais pas comment mais maintenant c'est le profil qui est affiché et les avatars qui apparaissent au survol du curseur. Quand j'essaie de tout remettre dans l'autre sens, les profils ne s'affichent pas
_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Author Message
Sploutch
Contributeurs


Offline
Contributeurs

Joined: 02 Jan 2006
Posts: 1,200
Niveau:
Point(s): 1,252
Moyenne: 1.04
Mac Safari Masculin

PostPosted: Sun 15 Dec 2019 - 10:01    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bonjour,



Je répète le support et/ou aide sur un tutoriel se fait à la suite !


Dans votre cas vous devrez repartir sur une base propre plutôt que de perdre du temps a chercher une erreur dans un code qui peut être devenu obsolète.

Merci
_______________________

Nous avons actuellement 386 Tutoriels ici pour personnalisez votre forum avec des exclusivités xooit !


Forum
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Sun 15 Dec 2019 - 13:08    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bonjour,

Je ne comprends plus le concept de ce forum alors, si c'est pour suivre un tutoriel sur un autre forum et aller demander de l'aide là-bas... Est-ce que cet autre forum fait parti de celui-ci ? Si c'est spécifié quelque part c'est bien caché...
De plus, je ne pense pas que le code soit devenu obsolète car il contient plus ou moins les mêmes choses que le tutoriel sur votre forum.

J'ai bien sûr essayé de tout remettre à neuf (avec le tutoriel sur l'autre forum mais aussi d'autres codes trouvé sur d'autres forums) parce que je souhaite évidemment régler ce problème pour lequel je viens chercher de l'aide, mais le problème persiste. Je viens sur le forum d’entraide parce que je ne parviens pas à détecter l'erreur moi-même, et que c'est là qu'on m'a déjà apporté des réponses.

Je préfère attendre que quelqu'un d'autre m'accorde du temps pour regarder et lire les codes que j'ai posté et m'indiquer où est l'erreur plutôt que de me faire répéter une solution qui ne fonctionne visiblement pas pour moi ou que "peut-être" mon code est devenu obsolète. Je n'appelle pas ça "perdre du temps" personnellement.

Je vous remercie pour vos réponses rapides et le temps que vous m'avez accordé cela dit.
Si quelqu'un d'autre a une idée d'où vient le problème je l'en remercie d'avance.
_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Author Message
Sploutch
Contributeurs


Offline
Contributeurs

Joined: 02 Jan 2006
Posts: 1,200
Niveau:
Point(s): 1,252
Moyenne: 1.04
Mac Safari Masculin

PostPosted: Sun 15 Dec 2019 - 13:55    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bonjour,


Yume-sama wrote:

J'ai bien sûr essayé de tout remettre à neuf (avec le tutoriel sur l'autre forum mais aussi d'autres codes trouvé sur d'autres forums) parce que je souhaite évidemment régler ce problème pour lequel je viens chercher de l'aide, mais le problème persiste. Je viens sur le forum d’entraide parce que je ne parviens pas à détecter l'erreur moi-même, et que c'est là qu'on m'a déjà apporté des réponses.

Je préfère attendre que quelqu'un d'autre m'accorde du temps pour regarder et lire les codes que j'ai posté et m'indiquer où est l'erreur plutôt que de me faire répéter une solution qui ne fonctionne visiblement pas pour moi ou que "peut-être" mon code est devenu obsolète. Je n'appelle pas ça "perdre du temps" personnellement.

Je vous remercie pour vos réponses rapides et le temps que vous m'avez accordé cela dit.
Si quelqu'un d'autre a une idée d'où vient le problème je l'en remercie d'avance.



Comment voulez-vous obtenir de l'aide sur des morceaux de template que vous donnez, avec dans la partie qui concerne les avatars des class qui dépende d'un .css que vous bidouillez tout comme votre template ou vous y allez à tâtons... !
Puis surtout avec vos précisions ...
Yume-sama wrote:
Installation miraculeuse (.... ) Je dis miraculeusement car déjà à l'époque ça ne fonctionnait pas toujours (...)

(message initial)

Sans parler de vos contradictions :
Yume-sama wrote:
je ne pense pas que le code soit devenu obsolète

Yume-sama wrote:
ne fonctionne visiblement pas pour moi ou que "peut-être" mon code est devenu obsolète.


Vous combinez des codes glaner ici et la, puis les comparez avec d'autres et bidouillez vos templates.
Yume-sama wrote:
mais aussi d'autres codes trouvé sur d'autres forums



Bref, vous voulez faire à votre manière, et de façon désorganisé avec un coté novice en codage ou vous voulez donner vos méthodes, et en plus il faut faire à votre façon !
Continuez à tourner en rond avec des messages qui ne servent à rien.


Si vous avez du temps a "tuer" moi non, je ne vais pas perdre mon temps pour rien, préfèrent consacré mon aide pour d'autres plus à l'écoute.
Et puis, comme je le dis souvent, chacun est libre ! Wink

Donc pas de souci pour moi, je vous souhaite bonne continuation et désolé d'avoir voulu vous venir en aide Okay

Vous savez ou me trouver si vous revenez à de bonnes résolutions pour être guidé intelligemment ainsi qu'efficacement et sans perte de temps.

Cdlt
_______________________

Nous avons actuellement 386 Tutoriels ici pour personnalisez votre forum avec des exclusivités xooit !


Forum
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Thu 19 Dec 2019 - 04:35    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bon je ne sais pas comment le dire autrement : j'ai mis en place EXACTEMENT votre solution, et ça ne fonctionnait toujours pas sur mon forum. Au lieu d'écouter ça, vous m'assurez que si si si ça fonctionne, alors je continue de chercher des indices pour se rapprocher du fond du problème, vous vous énervez pour que j'aille sur votre forum.


Sploutch wrote:
Bonjour,Comment voulez-vous obtenir de l'aide sur des morceaux de template que vous donnez, avec dans la partie qui concerne les avatars des class qui dépende d'un .css que vous bidouillez tout comme votre template ou vous y allez à tâtons... !
Puis surtout avec vos précisions ...

Sploutch wrote:
Continuez à tourner en rond avec des messages qui ne servent à rien.

Pourquoi ne pas me demander d'autres précisions dans ce cas ? Ou des screenshots ? Ou tous les templates ? Ou n'importe quoi ? Des choses utiles pour comprendre le problème.
Je ne vois pas comment progresser sans "bidouiller" comme vous dites. Je "bidouille" en faisant attention, pour essayer de comprendre ce qui ne va pas, sans jamais perdre le code original. Et je le fais parce que même si je demande de l'aide, il se peut que je parvienne à trouver la solution ou que la fréquentation du forum fait qu'aucune aide ne viendra éventuellement.



Sploutch wrote:
Sans parler de vos contradictions :

Yume-sama a écrit:
je ne pense pas que le code soit devenu obsolète

Yume-sama a écrit:
ne fonctionne visiblement pas pour moi ou que "peut-être" mon code est devenu obsolète.

Le "peut-être" que j'ai écrit faisait référence à votre réponse.
Sploutch wrote:
(...)dans un code qui peut être devenu obsolète.

Cela me donnait clairement l'impression que vous n'aviez pas lu mon code.



Sploutch wrote:
Bref, vous voulez faire à votre manière, et de façon désorganisé avec un coté novice en codage ou vous voulez donner vos méthodes, et en plus il faut faire à votre façon !

Oui je suis novice en codage, mais je sais faire des codes simples et les adapter à mes préférences, mais quand ça dépasse mes connaissances, je viens demander de l'aide. Il n'y a rien d'anormal à ça.
Ce n'est pas que je veux faire à ma manière, c'est parce que votre solution ne résout pas mon problème. Mais vous êtres trop borné pour l'entendre et vous me prenez de haut pour aucune raison !


Sploutch wrote:
Vous combinez des codes glaner ici et la, puis les comparez avec d'autres et bidouillez vos templates.

A aucun moment j'ai dit que je les avais combiné. J'ai essayé votre code. Toujours le même problème. J'ai donc essayé d'autres codes. En quoi c'est mauvais ? J'essaie de régler le souci. Et c'est de cette façon que font bien des gens que je croise sur d'autres forums, je ne sais pas pourquoi vous n'êtes pas au courant, publiant vous-même des tutoriels.


Bref, je ne vous ai pas demandé à vous personnellement de m'aider à régler mon problème alors si vous n'en avez pas envie (en me demandant pas d'autres précisions par exemple) je comprends parfaitement. Mais dans ce cas, merci de ne pas répondre dans ce sujet, qui a été créé pour ça.
_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Author Message
Yume-sama
Membre


Offline
Membre

Joined: 04 Mar 2011
Posts: 21
Niveau:
Point(s): 20
Moyenne: 0.95
Windows Vista ou 7 Chrome (ou l'un de ses dérivés : Chromium/Iron/...) Féminin

PostPosted: Tue 24 Dec 2019 - 05:08    Post subject: [Résolu] Profils en hover sur les avatars Reply with quote

Bonjour,

J'ai trouvé de l'aide et des explications sur un autre forum et mon code fonctionne parfaitement aujourd'hui. Je n'ai donc plus besoin de ce sujet. Merci de m'avoir donné la possibilité d'exposer mon problème Smile
Bonne journée à vous !
_______________________
Je réside au Japon, avec le décalage horaire je risque de mettre du temps à répondre


Forum
Display posts from previous:   
Reply to topic Page 1 of 1




Index | Administration Panel | Create a forum | Free support forum | Free forums directory | Report a violation | Cookies | Charte | Conditions générales d'utilisation
Propulsé par p h p B B © 2016 p h p B B Group |
 
© 2003-2020 Xooit.com - Contact - Mentions légales - CGU - Charte - CNIL : 1381401